Skip to content

WebPlayer Errors

Make us happy - post a bug!

WebPlayer Errors

Postby holyjewsus » 17 Dec 2012, 01:05

My player.log file is filled with these error messages:


Logic Block : Cast to creating error In GameObject : UNIVERSE Logic Container !
System.MethodAccessException: Attempt to access a private/protected method failed.
at System.Security.SecurityManager.ThrowException (System.Exception ex) [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicBlocksFactory.a () [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicBlocksFactory..ctor () [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicBlocksFactory.get_instance () [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicLoader.a (System.Collections.Generic.Dictionary`2 A_0, System.Collections.Generic.List`1 A_1, System.Collections.Generic.List`1 A_2, System.Collections.Generic.List`1 A_3, .VizioComponent A_4, Antares.Vizio.Runtime.LogicBlock A_5) [0x00000] in <filename unknown>:0

(Filename: /Applications/buildAgent/work/14194e8ce88cdf47/Runtime/ExportGenerated/WebPlayer/UnityEngineDebug.cpp Line: 43)

Variable not found in LogicBlock! Variable value ignored.

(Filename: /Applications/buildAgent/work/14194e8ce88cdf47/Runtime/ExportGenerated/WebPlayer/UnityEngineDebug.cpp Line: 43)

Variable not found in LogicBlock! Variable value ignored.

(Filename: /Applications/buildAgent/work/14194e8ce88cdf47/Runtime/ExportGenerated/WebPlayer/UnityEngineDebug.cpp Line: 43)

Variable not found in LogicBlock! Variable value ignored.

(Filename: /Applications/buildAgent/work/14194e8ce88cdf47/Runtime/ExportGenerated/WebPlayer/UnityEngineDebug.cpp Line: 43)

Variable not found in LogicBlock! Variable value ignored.

(Filename: /Applications/buildAgent/work/14194e8ce88cdf47/Runtime/ExportGenerated/WebPlayer/UnityEngineDebug.cpp Line: 43)

Couldn't extract exception string from exception (another exception of class 'ArgumentException' was thrown while processing the stack trace)
holyjewsus
 
Posts: 390
Joined: 08 Apr 2011, 00:58

Re: WebPlayer Errors

Postby holyjewsus » 17 Dec 2012, 01:05

standalone build works fine.
holyjewsus
 
Posts: 390
Joined: 08 Apr 2011, 00:58

Re: WebPlayer Errors

Postby holyjewsus » 17 Dec 2012, 01:10

also this error:


Logic Block : 'Type not found!' creating error In GameObject : UNIVERSE Logic Container !
System.MethodAccessException: Attempt to access a private/protected method failed.
at System.Security.SecurityManager.ThrowException (System.Exception ex) [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicBlocksFactory.a () [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicBlocksFactory..ctor () [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicBlocksFactory.get_instance () [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicLoader.a (System.Collections.Generic.Dictionary`2 A_0, System.Collections.Generic.List`1 A_1, System.Collections.Generic.List`1 A_2, System.Collections.Generic.List`1 A_3, .VizioComponent A_4, Antares.Vizio.Runtime.LogicBlock A_5) [0x00000] in <filename unknown>:0
holyjewsus
 
Posts: 390
Joined: 08 Apr 2011, 00:58

Re: WebPlayer Errors

Postby holyjewsus » 17 Dec 2012, 04:54

I don't know whats causing the interaction BUT having newtonsoft JSON.NET installed in my project anywhere in the project, was causing those errors in the webplayer, any ideas neodrop as this json library is very useful.

http://json.codeplex.com/releases/view/97986
holyjewsus
 
Posts: 390
Joined: 08 Apr 2011, 00:58

Re: WebPlayer Errors

Postby holyjewsus » 17 Dec 2012, 04:58

http://forum.unity3d.com/threads/50998- ... s-in-Unity

according to this thread, I should just switch as it might not be universe at all, but just json.net doing werid stuff.
holyjewsus
 
Posts: 390
Joined: 08 Apr 2011, 00:58

Re: WebPlayer Errors

Postby Neodrop » 27 Dec 2012, 01:29

It's not a Universe issue. it's a Unity protection methods exception. You can't access any private or protection methods in any classes (at least) in the WEB bilds.
User avatar
Neodrop
Администратор
 
Posts: 1068
Joined: 15 Jan 2011, 13:18

Re: WebPlayer Errors

Postby Kikimora » 22 Sep 2015, 13:55

Excellent !! really nice posts! thanks 
Kikimora
 
Posts: 15
Joined: 22 Sep 2015, 13:20


Return to Bugs

Who is online

Registered users: No registered users