Skip to content

Variables disappearing

Make us happy - post a bug!

Variables disappearing

Postby ren072 » 01 May 2014, 08:13

Hi,

I'm working with Universe every days, and this bug is appearing approximately one time a week, so it's not very easy to reproduce, though it's very annoying:
Sometimes, all variables in a graph disappear, and I have to reassign them manually. Even if I check backup graphs, all of them have also disappeared. That's why I always doing screenshots of my graphs so I can easily reassign variables.
I just had the bug one more time this morning. This time, it's a little bit different as it happened on a graph being on several gameobjects.
This is exactly the same graph saved on two different gameobjects. On the first one, variables have been lost. You can see the difference with the second one.
This bug is happening for years.
BackgroundButtons.png


BackgroundButtons02.png


It seems it's happening when I hit play and the Universe window is open. Variables are then lost on this particular graph.

I received some warnings in the console, but I don't know if they are related:
Type Antares.Vizio.UnityEngineBlocks.ObjectFindSceneObjectsOfTypeDo not found!
UnityEngine.Debug:Log(Object)
Antares.Vizio.Runtime.BinaryIO.BinaryExtender:eval_a(String)
Antares.Vizio.Runtime.LogicLoader:eval_b(VizioComponent, LogicBlock, Dictionary`2, List`1)
Antares.Vizio.Runtime.LogicLoader:DeserializeData(VizioComponent, LogicBlock, TextAsset)
VizioComponent:Deserialize()
VizioComponentEditor:eval_a()
VizioComponentEditor:RenderGizmo(Transform, GizmoType)
UnityEditor.DockArea:OnGUI()

Logic Block : 'Type not found!' creating error In GameObject : Select in Layer !
System.ArgumentNullException: Argument cannot be null.
Parameter name: type
at System.Activator.CheckType (System.Type type) [0x00006] in /Users/builduser/buildslave/monoAndRuntimeClassLibs/build/mcs/class/corlib/System/Activator.cs:378
at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00000] in /Users/builduser/buildslave/monoAndRuntimeClassLibs/build/mcs/class/corlib/System/Activator.cs:343
at System.Activator.CreateInstance (System.Type type) [0x00000] in /Users/builduser/buildslave/monoAndRuntimeClassLibs/build/mcs/class/corlib/System/Activator.cs:254
at Antares.Vizio.Runtime.LogicBlocksFactory.CreateLogicBlock (System.Type type, ILogicEnvironment environment, .VizioComponent component, Int32 id, System.String blockGid) [0x00000] in <filename unknown>:0
at Antares.Vizio.Runtime.LogicLoader.eval_a (System.Collections.Generic.Dictionary`2 A_0, System.Collections.Generic.List`1 A_1, System.Collections.Generic.List`1 A_2, System.Collections.Generic.List`1 A_3, .VizioComponent A_4, Antares.Vizio.Runtime.LogicBlock A_5) [0x00000] in <filename unknown>:0
UnityEngine.Debug:Log(Object, Object)
Antares.Vizio.Runtime.LogicLoader:eval_a(Dictionary`2, List`1, List`1, List`1, VizioComponent, LogicBlock)
Antares.Vizio.Runtime.LogicLoader:eval_b(Dictionary`2, List`1, List`1, List`1, VizioComponent, LogicBlock)
Antares.Vizio.Runtime.LogicLoader:eval_b(VizioComponent, LogicBlock, Dictionary`2, List`1)
Antares.Vizio.Runtime.LogicLoader:DeserializeData(VizioComponent, LogicBlock, TextAsset)
VizioComponent:Deserialize()
VizioComponentEditor:eval_a()
VizioComponentEditor:RenderGizmo(Transform, GizmoType)
UnityEditor.DockArea:OnGUI()

EntryTrigger not found!
UnityEngine.Debug:Log(Object, Object)
Antares.Vizio.Runtime.LogicLoader:eval_a(LogicBlock, LogicBlock, Object[], List`1)
Antares.Vizio.Runtime.LogicLoader:eval_a(Dictionary`2, List`1, LogicBlock)
Antares.Vizio.Runtime.LogicLoader:eval_b(VizioComponent, LogicBlock, Dictionary`2, List`1)
Antares.Vizio.Runtime.LogicLoader:DeserializeData(VizioComponent, LogicBlock, TextAsset)
VizioComponent:Deserialize()
VizioComponentEditor:eval_a()
VizioComponentEditor:RenderGizmo(Transform, GizmoType)
UnityEditor.DockArea:OnGUI()

TriggerLink "Exit" not found!
UnityEngine.Debug:Log(Object, Object)
Antares.Vizio.Runtime.LogicLoader:eval_a(LogicBlock, LogicBlock, Object[], List`1)
Antares.Vizio.Runtime.LogicLoader:eval_a(Dictionary`2, List`1, LogicBlock)
Antares.Vizio.Runtime.LogicLoader:eval_b(VizioComponent, LogicBlock, Dictionary`2, List`1)
Antares.Vizio.Runtime.LogicLoader:DeserializeData(VizioComponent, LogicBlock, TextAsset)
VizioComponent:Deserialize()
VizioComponentEditor:eval_a()
VizioComponentEditor:RenderGizmo(Transform, GizmoType)
UnityEditor.DockArea:OnGUI()

Variable "result" not found! Links ignored.
UnityEngine.Debug:Log(Object, Object)
Antares.Vizio.Runtime.LogicLoader:eval_b(LogicBlock, LogicBlock, Object[], List`1)
Antares.Vizio.Runtime.LogicLoader:eval_a(Dictionary`2, List`1, LogicBlock)
Antares.Vizio.Runtime.LogicLoader:eval_b(VizioComponent, LogicBlock, Dictionary`2, List`1)
Antares.Vizio.Runtime.LogicLoader:DeserializeData(VizioComponent, LogicBlock, TextAsset)
VizioComponent:Deserialize()
VizioComponentEditor:eval_a()
VizioComponentEditor:RenderGizmo(Transform, GizmoType)
UnityEditor.DockArea:OnGUI()

Variable not found in LogicBlock! Variable value ignored.
UnityEngine.Debug:Log(Object, Object)
Antares.Vizio.Runtime.LogicLoader:eval_a(List`1, List`1, List`1, LogicBlock)
Antares.Vizio.Runtime.LogicLoader:eval_b(VizioComponent, LogicBlock, Dictionary`2, List`1)
Antares.Vizio.Runtime.LogicLoader:DeserializeData(VizioComponent, LogicBlock, TextAsset)
VizioComponent:Deserialize()
VizioComponentEditor:eval_a()
VizioComponentEditor:RenderGizmo(Transform, GizmoType)
UnityEditor.DockArea:OnGUI()

Thanks
ren072
 
Posts: 154
Joined: 21 Jun 2011, 14:00
Location: Belgium

Re: Variables disappearing

Postby Neodrop » 01 May 2014, 11:16

Ok. Thank you. Will looking for it tomorrow
User avatar
Neodrop
Администратор
 
Posts: 1068
Joined: 15 Jan 2011, 13:18

Re: Variables disappearing

Postby ren072 » 01 May 2014, 16:47

Got it again on the same graph.
This time, I didn't hit play, I just did a screenshot.
I didn't received any error message.
I tried to restart Unity, but variables didn't reappeared.
ren072
 
Posts: 154
Joined: 21 Jun 2011, 14:00
Location: Belgium

Re: Variables disappearing

Postby Neodrop » 02 May 2014, 14:27

Can you send me some small project for testing? I can't reproduce this bug by myself.
User avatar
Neodrop
Администратор
 
Posts: 1068
Joined: 15 Jan 2011, 13:18

Re: Variables disappearing

Postby ren072 » 06 May 2014, 06:12

Would it be possible to only send a small package (GameObject + graph), not the whole project?
Mine is too big (>1GB).
ren072
 
Posts: 154
Joined: 21 Jun 2011, 14:00
Location: Belgium

Re: Variables disappearing

Postby Neodrop » 06 May 2014, 16:13

Yes, sure. Package is fine, I hope
User avatar
Neodrop
Администратор
 
Posts: 1068
Joined: 15 Jan 2011, 13:18


Return to Bugs

Who is online

Registered users: Bing [Bot], Yandex [Bot]